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1. 개요 

개요 

DataDraw란? 

DataDraw는 다양한 객체를 그리는 툴을 제공한다. 

DataDraw의 주요특징 

DataDraw는 다음과 같은 강력한 Graphic 기능을 제공한다. 

 Editor supports lightweight paint objects  

 Editor supports Windows controls (standard, custom and ActiveX)  

 VB Scripting and C++ callbacks of events Extensible  

 VB Scripting is modeless, property sheet (supports custom Properties)  

 Property format toolbars (for setting font, colors, etc.)  

 Office 2000 style dropdowns for color picking and other styles  

 Object alignment, spacing, Z-order, etc.  

 Rotation  

 Groups  

 Layers  

 Zooming and auto-scrolling  

 Rulers and guidelines  

 Line snapping with rules, auto-routing, etc.  

 Infinite levels of undo/redo 

 VBScript editor includes IntelliSense dropdowns and Wizard Browser  

 Sub-view containers  

 Create your own catalogues of drawing objects and symbols via drag & drop  

 Catalogues can also store raw text and bitmaps  

 Multiple catalogues open simultaneously  

 Edit catalogue icons and drawing bitmaps from within your app  
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 Drag & drop support for C Object, CF_TEXT, CF_DIB  

 Ability to add support for new (and custom) drag & drop formats  

 Ability to type catalogues, i.e., filter what can be drag & dropped  into them  

 Multiple catalogues can be open simultaneously  

 Ability to do operations (like Dado and Open) from menus and toolbars  

 View by icon, name, icon & name or in a single column (Outlook style)  

 Inline edit name text  

 Icon thumbnail automatically generated (and can select new icon from file)  

 Re-arrange catalogue using drag & drop  

 Rich set of look & feel attributes can be pre-set (colors, fonts, sizes, menus, etc.)  

 New catalogues can be created on-the-fly  

 Catalogues reside on dockable dialog bar  

 Full featured bitmap editor  

 Clipboard enabled: Cut/Copy/Paste/Delete  

 Multi-level undo/redo  

 10-600% magnification slider (600% = pixel editing)  

 Dynamic bitmap resizing and cropping  

 Text entry mode  

 Eye dropper  

 Flood fill / Erase / Pencil / Line  

 Fill or frame: rectangle, rounded rectangle, ellipse  

 Tear-off color picker  

 Transparency color picker  

매뉴얼 보는 방법 

이 매뉴얼은 DataDraw에 대한 정보만을 담고 있다. 

자세한 설명은 각 프로그램들의 Reference 매뉴얼을 참조 바란다. 

관련자료 

DataPlant Quick Start Guide (DPM-QUICK) 

DataPlant BaseApp Reference Manual (DPM-BASE) 
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DataPlant ViewApp Reference Manual (DPM-VIEW) 

DataPlant ReportApp Developer’s Manual (DPM-REPORT) 

추가정보 

DataPlant 에 대한 추가 사항 및 문의 내용은 Web 서비스를 이용하면 된다. 

Web 서비스 

Web 서비스 : http://www.dataplant.co.kr  

 

http://www.dataplant.co.kr/
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2. 화면 및 메뉴구성 

DataDraw 수행 

프로그램은C:\Program Files\DataPlant v3.8에 설치되며 시작->프로그램->DataPlant->DataDraw를 

수행하거나 DataPlant 초기화면에서 DataDraw icon를 수행하면 된다. 

 

그림 2-1 DataPlant 초기화면 
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초기화면 구성 

 

그림 2-2 DataDraw의 초기화면 

○1  Data Draw 메인 화면 

○2  Data Draw 메뉴 바 

③ Format Bar : 화면 크기설정, Insert Layer, Rotate Angle, Free Rotate, Edit points 

④ Font Bar : 글꼴, 글꼴크기, 강조, 기울임, Left, Center, Right 

⑤ Standard bar : 새 파일, 열기, 저장, 잘라내기 ,붙여넣기, 프린트, 도움말로 구성 

⑥ Layout Bar : Edit, View Script, Property Sheet, Object sheet, Layers  Sheet, Toggle Grid, 

View Snap Points, Toggle Ruler, Zoom In, Our, Group, Regroup, Align Edges, Center in View, 

Space, Make Same Size, To Front or  Back, Undo, Redo 

⑦ Object Bar 

⑧ 속성창(properties) 

⑨ 작업창창 

⑩ Catalog Bar 

⑪상태 Bar 
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메뉴구성 

Title Bar 

DataDraw화면의 상단에 항상 고정되어 나타나는 Bar로 현재 작업하는 파일명이 나타난다. 

Menu Bar 

 

그림 2-3 메뉴화면 

DataDraw의title Bar 바로 밑에 고정되어 나타나는 Bar로  각종 조작에 필요한6개의 Main 

Menu즉File, Edit, View, Layout, Draw, Window, Help 예시되어 있다. 각  Main Menu들을 선

택하면 그들의 Sub Menu창이 바로 밑에 붙어 나온다. 이장에서 Menu Bar를 이용하여 특

정 기능을 선택할 때  Main->Menu->Sub Menu의 식으로 표시할 것이다. 

예를 들어 File->New는File Menu에서 다시 New 메뉴를 선택하는 것이다. 

조작메뉴에 대한 설명은 아래의 메인 메뉴에 대한 설명을 참조 할 것 

주 메뉴 보조메뉴 용도 단축키 

File(F) New 작업파일 새로 만들기  

 Open 작업파일을 연다 Ctrl + O 

 Close 작업파일을 닫기 Ctrl + F4 

 Save 작업파일 저장 Ctrl + S 

 Save As 다른 이름으로 저장  

 Print 화면 프린트 Ctrl + P 

 Print Preview 프린트 미리보기  

 Print Setup 프린터 설정  

Edit(E) Undo 최근 작업을 취소하기 Ctrl + Z 

 Redo 취소된 작업을 다시하기  

 Cut 선택부분을 잘라내기 Ctrl + X 

 Copy 선택부분을 복사하기 Ctrl + C 

 Paste 붙여넣기  

 Paste Special 특별하게 붙여넣기  

 Delete 선택부분을 삭제하기 Del 

 Add to Catalogue 선택부분을 카다로그로 추가  
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 개체 OLE 개체를 삽입  

View(V) Tool Bars 툴 바 보기  

 Status Bar 상태 바 보기  

 Ruler Bars Rule바 보기  

 Snap Point Snap Point 보기  

 Catalogue 카다로그 창 보기  

 Run Preview 실행화면 미리보기  

 Bird Eye View 실행화면 작게 미리보기  

 Full Screen 전체화면으로 보기  

Layout(L) Align Object 왼쪽,오른쪽,위,아래로 정렬  

 Space Evenly 옆, 아래로  같은 공간으로 정렬  

 Center In View 화면 중간지점으로 이동  

 Make Same Size 같은 크기로 크기변경  

 Layers Layer창 보기  

 Properties 속성창 보기 Ctrl + L 

 Grid Setting Grid의 속성 설정  

Draw Order 앞,뒤, 맨 뒤, 맨 앞으로 이동  

 Zoom 화면확대,축소  

 Group Symbol들의 Grouping  

 Rotate 회전  

 Contour 다각형 객체 수정  

 AutoUpdate 자동업데이트  

 Pan Mode 팬 모드  

Script Edit Form 그리기 화면  

 Edit Script 스크립트 화면  

 Main Script 메인 스크립트 화면  

Tools List 객체 리스트  

 Check Mnemonics 기억 확인  

 Import WMF WMF 이미지 추가  

 Save Symbols 심볼로 저장  

 Load Symbols 심볼 불러오기  

Window Next 다음화면  

 Prev 이전화면  

 Cascade 연속정렬  

 Tile Horizontal Tile 가로정렬  

 Tile Vertical Tile 세로정렬  
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 Arrange Icons 재배치  

 …. 열려있는 창 목록  

Help Help Topics 도움말 보기  

 About DataDraw DataDraw 정보보기  

Format Bar 

 

 
    ⓐ     ⓑ           ⓒ           ⓓ       ⓔ   ⓕ 

 

그림 2-4 Format Bar 

DataDraw의 전체 화면 zoom in/out 비율 설정, layout 설정, 선택된 객체의 회전 시 회전

각도 설정 등을 조절할 수 있게 해준다. 

ⓐ 화면 전체의 zoom in/out 비율을 숫자 혹은 정해진 비율만큼 set한다.  설정 즉시 화면

이 정해진 비율만큼 zoom in/out된다. 

ⓑ 화면 비율이 100% 가 아닐 때 즉zoom in/out가 된 상태 일 때 이 아이콘이 활성화되

며 이 아이콘을 누르면 화면 비율이 100%로 원상 회복된다. 

ⓒ Multi-Layer로 작업을 할 경우 Layer를 선택할 수 있게 한다. 자세한 설명은 Layer활용

을 참조할 것. 

ⓓ 선택된 회전 가능한 Object들을 일정 각도 만큼 회전시킬 때 회전 각도를 설정한다. 

ⓔ 선택된 회전 가능한 Object들을 임의의 각도로 회전시킬 때 이 아이콘을 사용한다. 

ⓕ 선택된 Polygon Object의 편집 시 이 아이콘을 사용한다. 

기본적으로 이 Bar는 사용자에 의해서 크기조절 및 이동이 가능하며 View->Tool 

Bar->Another Bar 메뉴를 이용하여 활성화 여부를 사용자가 선택할 수 있다. 

Font Bar 

선택된 object의font , 텍스트 정렬, 그램이 앞뒤배경 색,Pen Width, Pen Style, 화살표 방향 

등을 조절할 수 있게 해준다. 
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그림 2-5 Font bar의 구성 

ⓐ 선택된 Object내이 text 또는 선택된 Text Object의 폰트,크기,기울임,  굵게 표시 등을  

조절할 때 사용함. 

ⓑ 선택된 Object내이 text 또는 선택된 Text Object의 좌,우,중간 정렬  을 선택할 때 사용

함. 

ⓒ 선택된 Object의 뒤 배경 색깔을 정할 때 사용함. 오른쪽 아래 방향 화살표를 선택하면 

색상 table이 예시되어 사용자는 임의의 색을 마음대로 지정할 수 있다. 

ⓓ 선택된 Object의 앞 배경 색깔을 정할 때 사용함. 오른쪽 아래 방향 화살표를 선택하면 

색상 table이 예시되어 사용자는 임의의 색을 마음대로 지정할 수 있다. 

ⓔ 선택된 선형 Object들의 선 굳기, 화살표 방향, 선 모양을 조절할 때 사용 함. 

기본적으로 이 Bar는 사용자에 의해서 크기조절 및 이동이 가능하나 활성화 여부를 사용

자가 선택할 수 없다 

Standard Bar  

작업한 화면의 생성, 저장, 기 작업 화면의 열기, 파일 출력 등 기본적인 파일 조작에 대한 

메뉴 아이콘을 제공하며 선택된 object의Copy ,Cut ,Paste 조작에 대한 메뉴 아이콘을 제공 

한다. 
 

 ⓐ  ⓑ  ⓒ    ⓓ  ⓔ   ⓕ  ⓖ  ⓗ  ⓘ  ⓙ  

그림 2-6 Standard bar 구성 

ⓐ 선택을 하면 새로운 작업파일 인untitled1.dvw가 생성된다 (File->New와 동일) 

ⓑ 기존의 작업파일을 연다 (File->Open와 동일) 

ⓒ 현재 작업파일을 현재 파일이름으로 저장한다. (File->Save와 동일)  

ⓓ 선택된 Object들을 잘라냄 (Edit->Cut와 동일) 

ⓔ 선택된 Object들을 복사함 (Edit->Copy동일) 

ⓕ 잘라내거나 복사된 Object들을 지정한 화면위치에 갖다 놓음 (Edit->Paste와 동일) 

ⓖ 현재 작업 파일을 프린터로 출력한다. (File->Print와 동일) 
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ⓗ 현재 사용중인 DataDraw 프로그램 정보를 표시 (Help->About DataDraw와 동일) 

ⓘ DataDraw의 도움말 찾기 ( Help->Help Topics와 동일 ) 

Layout Bar   

DataDraw에 고유한 Bar로 다음과 같은 기능의 작업화면/스크립트 화면 전환, Property 

Sheet, Object Sheet, Layers Sheet 창의 활성화에 필요한 메뉴아이콘을 제공한다.  

 
ⓐ ⓑ  ⓒ ⓓ ⓔ   ⓕ ⓖ ⓗ ⓘ   ⓙ ⓚ ⓛ   ⓜ  ⓝ  ⓞ  ⓟ   ⓠ  ⓡ  ⓢ 

 

그림 2-7 Layout bar 구성 

ⓐ Script 작성 화면에서 작업화면으로의 전환 아이콘 (Layout->Edit Form과 동일) 

ⓑ 작업화면에서 Script 작성화면으로의 전환 아이콘 (Layout->Edit Script와 동일) 

ⓒ Property Sheet창을 활성화 시킨다. (Layout->Property와 동일) 

ⓓ Object Sheet창을 활성화 시킨다. (Layout->Object와 동일) 

Object Sheet창은 위의 예제 그림에 나타나 있지 않으나 현재 화면상의 모든 Object들의 

종류와 이름을 일목요연하게 표시하는 창이다. 

ⓔ Layer Sheet창을 활성화 시킨다. (Layout->Layer와 동일) 

Layer Sheet창은 위의 예제 그림에 나타나 있지 않으나 현재 화면상의 모든 Layer들 이 일

목요연하게 표시하는 창으로 각각의 Layer들도 사용자가 조절할 수 있다. Layer에 대한 보

다 자세한 설명 은Layer활용을 참조할 것  

ⓕ 작업화면의 Pixel 단위 Grid 표시를 보이거나 보이지 않게 하는 Toggle메뉴 아이콘

(Layout->Grid Settings 화면은 이보다 더 많은 것을 조절할 수 있다.) 

ⓖ 작업 화면 위의 각 객체 마다 Snap Points를 보이거나 보이지 않게 하는 Toggle메뉴 아

이콘 특히 Connector Object를 이용하여 각Object들을 연결할 때 유용하다. (View->Snap 

Points와 동일) 

ⓗ 작업 화면의 ruler (화면 가로세로 자가 나타남 )를 보이거나 보이지 않게 하는 Toggle 

메뉴 아이콘 (View->Ruler Bar와 동일 ) 

ⓘ 작업화면과 작업 화면 위의 모든 객체들을 Zoom Out하는 아이콘. 오른쪽 아래 방향 화

살표를 이용하면 Zoom In, Zoom Out, Zoom 1:1기능 모두를 선택할 수 있다(Draw->Zoom 

메뉴와 동일) 

ⓙ 복수개의 Object들을 선택할 때 활성화 되며 이들 선택된 Object들을 하나의 group로 

묶는다. (Draw->Group->Group 메뉴와 동일) 

ⓚ 작업화면에서 group화 된object들을 선택할 때 활성화 되며 Group을 해제한다. 
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(Draw->Group->Ungroup메뉴와 동일 )  

ⓛ 작업화면에서 Group 해제된 Object들을 다시 Group화 한다. 

(Draw->Group->ReGroup 메뉴와 동일) 

ⓜ 작업화면에서 복수개의 Object들을 선택할 때 활성화 되며,오른쪽 아래 방향의 화살표

를 이용하여 선택된 Object들을  상,하,좌,우 선택에 맞추어 정렬 한다.( Layout->Align 

Objects->Top, Layout->Align  Objects->Bottom, Layout->Align Objects->Left, 

Layout->Align Objects->Right 메뉴들과 동일) 

ⓝ 작업화면에서 단일 또는 복수개의 object들을 선택할 때 활성화 되며 오른쪽 아래 방향

의 화살표를 이용하여 화면 전체에서의 좌우, 높이 중간 지점으로의 이동이 가능하다. 

(Layout->Center In View->Vertical, Layout->Center In View->Horizontal 메뉴와 동일) 

ⓞ 작업화면에서 복수개의 Object들을 선택할 때 활성화 되며, 오른쪽 아래 방향의 화살표

를 이용하여 상하 좌우 같은 간격으로 정렬한다. (Layout->Space Evenly->AcrDPs, 

Layout->Space Evenly->Down메뉴와 동일) 

ⓟ 작업화면에서 복수개의 Object들을 선택할 때 활성화 되며, 오른쪽아래 방향의 화살표

를 이용하여 선택된 복수개의 object들의 폭, 높이, 또는2가지 모드 같은 크기로의 변경이 

가능하다. (Layout->Make the Same Size->Width, Layout->Make the Same Size->Height, 

Layout->Make the Same Size->Both 메뉴와 동일) 

ⓠ 겹쳐지는 복수개의 Object 조작 시 오른쪽 아래 방향의 화살표를 이용하여 선택된 해

당 Object의 앞, 뒤, 맨 뒤, 맨 앞으로 이동 (Draw->Order->Bring to Front, 

raw->Order->Bring to Back, Draw->Order->BringForward, Draw->Order->Backward와 동일) 

ⓡ 최근 드로잉 작업을 취소함.계속 누르면 이전 작업이 순서대로 취소됨( Edit->Undo메뉴

와 동일) 

ⓢ Undo 작업을 취소함 계속 누르면 이전의 Undo 작업이 순서대로 취소됨( Edit->Redo 

메뉴와 동일) 

 

Object Bar 

DataDraw상에서 기본적으로 제공하는 Symbol들과 ActiveX, OLE등을 사용자가 꺼내어 쓸 

수 있도록 제공되는 창이다. 

사용자는 이 창에서 해당 OBJECT들을 드래그 앤 드롭으로 꺼내어 작업 화면상의 원하는 

위치에 갖다 놓는다.  
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그림 2-8 Object bar의 구성 

Properties Sheet창 

선택된 객체들의 모든 속성을 보여준다. 사용자는 이 창에서 속성을 변경한다. 

 

그림 2-9 Properties 구성
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3. Draw File 작성 s 

Draw File 생성 

새 파일  

View파일들은 Object들을 저장할 수 있는 화면을 작성하는 것으로 한View화면 당 하나의 

파일이 생성된다. (단축키 : Ctrl + N) 

초기설정 값은 untitled1.dvw임. 

 

그림 3-1 DataDraw의 초기화면 

File 열기 

기존에 작성에 File을 읽어 올 수 있다. (단축키 : Ctrl + O) 

확장자는 DataPlant Draw File인 *.dvw이다. 
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그림 3-2 파일열기 

File 저장 

작업한 내용을 저장할 때 이용된다. (단축키 : Ctrl + S) 

처음 작업 한 내용은 ‘다른 이름으로 저장’으로 저장된다. 

 

그림 3-3 파일저장 

Object작업 

Object삽입/삭제 

화면 : 새로운 편집화면을 작성하면 기본적으로 만들어 진다.  

화면을 제외한 object들  

 Object Bar 창이나 catalog 창에서 Drag & Drop으로 끌어 당겨서 만든다. 

 캔버스 위의 이미 만들어진 Object들을 복사/붙여넣기 하여 만들기도 한다. 
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그림 3-4 Object의 삽입 

Object이동 

Object이동은 해당 object를 선택한 후Mouse왼쪽 버튼을 누른 채 원하는 장소로 이동한

다. 

혹은 화살 키 들을 활용하여 1 pixel씩 이동도 가능하다.  

 

그림 3-5 Object의 이동 

Object크기 

Object이동은 해당 object를 선택한 후 왼쪽하단을 Mouse로 크기를 변경한다. 
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Shift키를 누른 채 해당 화살표를 활용하면 1 pixel씩 크기조정이 가능하다.  

 

그림 3-6 Object의 크기조정 

Bitmap 

외부의 Bitmap, jpg, icon등을 작업중인 문서에 삽입 할 수 있다. 

 

그림 3-7 이미지 삽입 

Link를 사용한 경우 project를 copy혹은 backup할 경우 해당 image를 같이 

저장해야만 한다. 

Multi-Selection 

Object들은 여러 개를 묶어서 전체적으로 공통의 Event를 부여할 수 있다. 
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만약 Grouping된Object, 혹은 여러 Object들이 선택된 경우 속성창의 오른쪽 위의 1 By 1 

의Checkbox가 활성화 된다. 

이 경우 Event부여 방법은 위의 Grouping과 동일하다. 

Object편집 

아래와 같은 object의 이동, 크기조절, Group/Ungroup, 정렬 등의 기능을 제공한다. 

 이동 : 마우스가 아닌 해당 화살 키를 이용할 경우  1 pixel씩 이동 가능 하다. 

 크기조절 : 마우스가 아닌 Shift + 해당 키를 이용할 경우1 pixel씩 크기가 조절 가능

하다. 

 위치 정렬 : 선택된 복수개의 object들의 상하좌우 정렬이 가능하다. Menu Bar의

Layout->Align Objects의 서브 메뉴를 이용한다. 

 공간 정렬 : 선택된 복수개의 object들이 상하 좌우 같은 간격으로의 정렬이 가능하

다. Menu Bar의Layout->Space Evenly의 서브 메뉴를 이용한다. 

 화면상에서의 정렬 : 단일 또는 선택된 복수개의 object들의 화면 전체에서의 좌우 

높이 중간지점으로의 이동이 가능하다. Menu Bar의Layout->Center In view의 서브 

메뉴를 이용한다. 

 같은 크기 : 선택된 복수개의 object들의 폭,높이,또는2가지 모두 같은 크기로의 변

경이 가능하다. Menu Bar의Layout->Center In view의 서브 메뉴를 이용한다. 

 순서 : 겹쳐지는 복수개의  object 조작 시 선택된 해당 object의 앞,뒤,맨 뒤,맨 앞

으로의 이동이 가능하다. 

 Group/ungroup/regroup : 선택된 복수개의 object들에 대해 해당 조작이 가능하다 

View메뉴 

Tool bars 

체크박스를 이용하여 툴 바를 활성화 한다. 

Status bar 

상태 바를 표시한다. 
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Ruler bars 

화면에 막대자 표시를 한다. 

Snap Point 

화면의 객체에 Snap Point를 표시한다. 

Catalogue 

카탈로그 화면을 활성화 한다. 

Run Preview 

화면은 DataView를 사용하지 않고도 미리 보기를 할 수 있다. 

 View Run preview (단축키F5) 

미리보기 창은 메뉴-> close를 이용하여 닫을 수 있다. 

Birds Eye View 

작게 미리보기 

Full Screen 

전체화면 
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Layout메뉴 

Align Object 

여러 개의 Object를 선택하여 정렬한다. 

Space Evenly 

옆, 아래로  같은 공간으로 정렬한다. 

Center in View 

화면의 세로기준 중앙 또는 가로기준 중앙으로 정렬한다. 

Make Same Size 

선택된 객체들을 동일한 크기로 변경한다. 

Layer 

Layer기능은 Symbol들의 속성이 비슷한 개체들을 모아서 별도의 작업 Layer로 이동할 수 

있으며 각각의 Layer들은 가리기, 잠그기 기능을 활용하여 복잡한 도면을 효과적으로 관리, 

표현이 가능케 한다. 

잠김 기능을 설정하면 Layer를 보호 할 수 있다. 
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그림 3-8 Layer 지정 

Properties 

속성 창을 활성화 시킨다. 

Grid Setting 

Guideline은 초기치 여백이 10pixel로 설정되어 있으며 이 여백을0으로 설정하면 전체 공

간을 활용할 수 있다. 

 

그림 3-9 여백 조정 



Chapter 3  Draw File 작성s   3-9 

 

Draw메뉴 

Order 

객체의 순서를 정한다. 

Zoom 

화면 확대 및 축소 기능으로 50%, 100%, 150%, 200%, 300%, 400% 설정 할 수 있다.  

제공 되는 크기와 별도로 사용자가 입력 한 크기로 화면을 볼 수 있다. 

1:1비율로 바로 볼 수 있다. 

 

그림 3-10 화면크기 조정 

Group 

Group/UnGroup하기 

Group을 하고자 하는 symbol들을 Shift Key를 누른 채 해당 symbol을 mouse로 click하여 

모두 선택한다. 그리고 Draw->Menu->Group을 선택하거나 하단의 Group Button을 이용하

여 Grouping 한다. 
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그림 3-11 Group 지정 

Group한 개체의 공통 Event 부여하기 

다중 object는 한번에 group하여 object의 어느 곳을 click하여도 공통의 event를 생성하게 

할 수 있다. 1 By 1을 uncheck한 경우가 이런 경우이며 Event는Object에 공통으로 동작한

다. 

Group한 개체의 개별 Event 부여하기 

1 By 1을 check한 경우에 해당하며 Event는 선택된 Object에 개별적으로 동작한다. 해당 

Object는 상단의 ComboBox를 이용하여 선택한다. 

Rotate 

선택한 객체를 회전한다. 

Contour 

다각형 객체의 그려진 부분을 마감하여 닫거나, 그려진 다각형 객체를 수정한다. 
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메뉴 

메뉴 -> Draw -> Contour 

EditPoints 

삽입된 point들을 수정하는 모드로 변환된다. 

Open/Close 

처음과 끝점을 연결할 지 결정한다. 

 

Auto Update 

AutoUpdate를 설정해서 개체에 대한 지정된 ValueEq와 ValueSet Tag값을 동시에 등록 할 

수 있다. 

Pan Mode 

Pan 모드로 변환한다. 

Script메뉴 

Edit Form 

그림화면에서 작업한다. 

Edit Script 

Script 화면에서 작업한다. 

Main Script 

Main Script 화면에서 작업한다. 
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Tools메뉴 

List 

현재 화면내의 객체 리스트를 볼 수 있다. 

Import WMF 

WMF형식으 이미지 파일을 불러올 수 있다. 

Save Symbols 

심볼로 저장 할 수 있다. 

Load Symbols 

심볼을 불러 올 수 있다. 
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4. Symbol 작성 

개요 

Symbol들은 현장 데이터와 직접 연결이 안 되는 정적 개체와 연결 가능한 동적개체로 나뉘어진다. 

또한 ActiveX 개체들로 구성된 Component와 기타 시스템에 설치되어 있는 객체들을 삽입할 수 있

다. 

속성창(Properties) 

속성창은 Windows 기본 기능 및  Visual Basic 6.0의 기본 기능과  비슷하게 설계되어 있어 편리하

게 사용할 수 있다. 

Normal 

대부분 object에 사용되는 공통의 속성은 다음과 같다. 
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그림 4-1 Properties의Normal 구성 

Alignment 

Object에 나타나는 Text의 위치를 지정하며 다음과 같은 설정이 가능하다. 

 Left : Text 위치를 왼쪽으로  정렬함. 

 Center : Text 위치를 가운데로 정렬함. 

 Right : Text 위치를 오른쪽으로 정렬함. 

Toolbar에 제공되는 icon으로 작업한다 

BackColor / ForeColor 

 Back Color : 삽입한 Object의 배경색을 변경하는데 사용. 

 Fore Color : 삽입한 Object의 선 색을 변경하는데 사용. 

BorderStyle 

작업창의 크기를 조정 및 고정으로 사용할 수 있다. 

 0 - Thin : 작업 창의  크기를 고정으로 사용할 수 있다. 사용자가 크기조정 불가. 

 1 - Resizing : 작업 창의 크기를 사용자 임의의 크기로 수정하여 사용 할 수 있다. 

FlexHorizontal / FlexVertical 

Object의 수평/수직 크기가 View화면의 크기에 비례하여 자동으로 축소/확대 되는 기능  
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 None 

 Shift – Object의 크기는 고정한 채 위치를 자동 변경 

 Expand – Object의 좌측상단의 위치를 고정한 채 크기 변경 

 Proportional – Object의 위치와 크기를 자동변경 Menu  Layout  Center In View

에서 작업할 수 있다. 

Font 

삽입한 Object및Text의 글꼴을 변경하는데 사용한다. 

Height/Width 

크기와 폭을 지정한다.  

Layer 

하나의 이미지가 여러 개의 층 구조를 가진 것으로 Object작업 시 서로 다른 Layer를 사

용하여 작업을 할 수 있고 Layer 잠금 기능을 사용하면 잠긴 Layer에 대해서는 수정 할 수 

없어 다른 Object에 영향을 주는 것을 방지 할 수 있다. 

Left/Right/Top/Bottom 

선택된 여러 개의 Object들의 정렬에 사용된다. 

RotateAngle 

삽입한 개체를 회전할 때 사용된다. 

Text 

Object에 나타나는 Text를 지정한다.  

Text에 &를 지정하면 (ALT + 해당 단축키)를 이용하여 이동이 가능하다. 

Top 

상단으로부터의 위치값 
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Visible 

객체가 runtime시 보이게 할 지 여부를 지정한다.  

 0 – NO : Runtime시 개체를 보이지 않게 한다. 

 1 – Yes : Runtime시 개체를 보이게 한다. 

Dynamics 

대부분 object에 사용되는 공통의 Dynamics 들은 다음과 같다. 

 

그림 4-2 Properties Dynamics 구성 

Confirm 

 0 – No : 사용안함 

 1 – Yes : 사용 

CursorPointer 

개체에 마우스 포인터가 있을 경우 표시되는 마우스 포인터의 형식을 지정한다. 

 0 – Default : 기본 설정 

 1 – Arrow : 화살표 

 2 – Ibeam : I빔 

 3 – Cross : 십자형 

 4 – UpArrow : 위쪽 화살표 
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 5 – NoDrop : 놓기 못 

 6 – Help : 화살표와 물음표 

 7 – Hand : 지시하는 손가락 

 8 – AppStarting : 화살표와 실행표시 

 9 – HArrow : 지시하는 손가락(소매표시) 

 99 – HotSpot : 사용자 정의 

DynBlink 

사용자가 등록한  Item과 Tag정보를 비교하여 지정한 개체에 대해 DynBlink 기능을 제공

한다. 

비교 값을  등록하여 비교 값에 따라 개체의 상태를 달리 표현할 수 있다. 

 

그림 4-3 DynBlink 구성 

Mode : 비교식 

 EQ(==) 

 GE(>=) 

 LE(<=) 

 LT(<) 

 VBScript 

Tag : 비교 대상(비교할 대상을 선택한다.) 

Value : 비교 값(사용자가 비교할 값을 설정한다.) 
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DynColor 

사용자가 등록한 Item과 Tag정보를 비교하여 지정한 개체에 대해 DynColor 기능을 제공한

다. 

비교 값을 등록하여 비교 값에 따라 개체의 상태를 달리 표현할 수 있다. 

 

그림 4-4 DynColor 구성 

Mode : 비교식 

 EQ(==) 

 GE(>=) 

 LE(<=) 

 LT(<) 

 VBScript 

Tag : 비교 대상(비교할 대상을 선택한다.) 

Value : 비교 값(사용자가 비교할 값을 설정한다.) 

DynVisible  

사용자가 등록한 Item과 Tag정보를 비교하여 지정한 개체에 대해 DynVisible 기능을 제공

한다. 

비교 값을 등록하여 비교 값에 따라 개체의 상태를 달리 표현할 수 있다. 
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그림 4-5 DynVisible 구성 

Mode : 비교식 

 EQ(==) 

 GE(>=) 

 LE(<=) 

 LT(<) 

 VBScript 

Tag : 비교 대상(비교할 대상을 선택한다.) 

Value : 비교 값(사용자가 비교할 값을 설정한다.) 

Enable 

사용자가 만든 Event에 대해 개체가 응답할 수 있는지의 여부를 결정하는데 사용 

 0 – No : Event에 대해 개체가 응답을 할 수 없다 

 1 – Yes : Event에 대해 개체가 응답 한다. 

HelpContextID 

개체에 대한 기본 도움말 파일 컨텍스트 ID를 지정할 때 사용한다. 
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Tag 

 

ToolTipText 

마우스가 컨트롤에 일시 정지되어 있을 때 표시되는 텍스트를 반환할 때 사용한다. 

ValueEq/Set 

태그를 연결하고자 할 때 사용한다. 

ValueEq 

데이터 값을 읽어와 표시하고자 하는 태그 값 

ValueSet 

데이터 값을 쓰고자 하는 태그 값 

 

그림 4-6 ValueEq/Set 

 CONST : 상수값을 지정 

 +EQ[$] : 태그에서 받아오는 값을 양수로 표시 

 -EQ[$] : 태그에서 받아오는 값을 음수로 표시 

 VBScript : VBScipt를 사용하여 표시 

Event 

모든 개체는 Mouse나Keyboard 혹은 데이터 변환의 Event가 발생되었을 때 적절한 Script

와 연계하여 기능을 추가 할 수 있다. 
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Script는Visual Basic과 호환의 문법을 가지고 있으며 내장된 편집화면을 사용하여 다음과 

같이 편집 가능하다. 

대부분 object에 사용되는 공통의 Event들은 다음과 같다. 

 

그림 4-7 Properties Events 구성 

EventClick 

Parameters : None 

Remarks 

Example 

EventDblClick 

Parameters : None 

Remarks 

Example 

EventDragDrop 

Parameters : Data, Effect, Button, Shift, X, Y 

Remarks 

Example 
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EventDragEnter 

Parameters : Data, Button, Shift, X, Y 

Remarks 

Example 

EventDragOver 

Parameters : Data, Effect, Button, Shift, X, Y 

Remarks 

Example 

EventInitialize 

Parameters : None 

Remarks 

Example 

EventTerminate 

Parameters : None 

Remarks 

Example 

EventDSC 

Parameters : Objdscdata 

Remarks 

Example 

EventKeyDown 

Parameters : Key, Shift, Control 

Remarks 

Example 
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EventKeyPress 

Parameters : Key, Shift, Control 

Remarks 

Example 

EventKeyup 

Parameters : Key, Shift, Control 

Remarks 

Example 

EventMouseDown 

Parameters : Button, Shift, X, Y 

Remarks 

Example 

EventMouseMove 

Parameters : Button, Shift, X, Y 

Remarks 

Example 

EventMouseUp 

Parameters : Button, Shift, X, Y 

Remarks 

Example 

EventPumpData 

Parameters : None 

Remarks 

Example 
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ActiveX 

Symbol이ActiveX인 경우 속성 창에 추가로 설정이 가능하다. 

내용은 Normal과 비슷하며 각각의 object에 따라 결정된다. 

 

그림 4-8 Properties ActiveX 구성 

Method 

대부분 object에 사용되는 공통의 method들은 다음과 같다. 

Symbols 

Sub Move (ByVal P1 As Long, ByVal P2 As Long) 

 P1 = x축의 이동 거리 

 P2 = y축의 이동 거리 



Chapter 4  Symbol 작성   4-13 

 

Function Layout Name() As String 

 Sub On Update() 

 Sub On Update Resize() 

 Sub Run Click() 

 Sub Run Initialize() 

 Sub Run Pump data() 

Frame/View 

Normal 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Border Style 

작업창의 크기를 조정 및 고정으로 사용할 수 있다. 

 0 - Thin : 작업 창의  크기를 고정으로 사용할 수 있다. 사용자가 크기조정 불가. 

 1 – Resizing : 작업 창의 크기를 사용자가 원하는 사이즈로 변경한다. 

Color 

작업창의 배경 화면의 색 조정을 할 수 있다. 

Print Scale 

프린터로 출력할 축소/확대 비율을 지정한다. 1보다 작은 값 이면 축소되어 인쇄된다. 

Scroll Bars 

 0 – No : Scroll Bars를 사용하지 않음 

 1 – Yes : Scroll Bars를 사용함 
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Scroll Height 

작업창의 가로 크기 지정 

Scroll Width 

작업창의 세로 크기 지정 

Show Border 

작업창의 개체 테두리의 사용여부를  지정할 때 사용 

Show Title 

상단의 타이틀 바를 나타낼지 의 여부를 설정한다. 

Modal로 나타난 화면은 ShowTitle의 속성과 관계없이 항상 상변의 타이틀 바

가 나타난다. 

Title 

상단의 타이틀 바에 제목을 입력 할 때 사용한다. 

View Layers 

작업 창에 Layers 추가 및 삭제를 할 수 있다. 

What’s This Help 

도움말 사용을 설정 할 수 있다. 

Dynamics 

Auto Record 

 0 – No : 현재 화면에서 편집된 데이터를 자동으로 저장하지 않고 종료 시 물어봄 
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 1 – Yes : 데이터를 입력 즉시 저장함 

 2 – Detach : 현재 화면에서 편집된 데이터를 Frame 종결 시 자동으로 저장함. 

Maximize Box 

 0 – No : 작업창의 크기를 최대화 못하게 한다. 

 1 – Yes : 작업창의 크기를 최대화 활성화 한다. 

Minimize Box 

 0 – No : 작업창의 크기를 최소화 하는 것을 방지 

 1 – Yes : 작업 창 크기를 최소화를 활성화 한다. 

Report Lock 

View안의 dynamic object들이 update되는 것을 정지시킴 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

Sub GotoView (ByVal P1 As String, ByVal P2 As Long, ByVal P3 As Long) 

새로운 화면으로 이동하며 현재 화면은 사라진다. 

 P2 = x축의 이동 거리 

 P3 = y축의 이동 거리 

Sub ShowView (ByVal P1 As String, ByVal P2 As Long, ByVal P3 As Long) 

현재 화면은 유지한 채 새로운 화면이 나타난다. 

 P2 = x축의 이동 거리 

 P3 = y축의 이동 거리 
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Sub ShowModal (ByVal P1 As String, ByVal P2 As Long, ByVal P3 As Long) 

Modal 창이 나타난다. 

 P2 = x축의 이동 거리 

 P3 = y축의 이동 거리 

동적 Symbol 

Arc 

곡선 작업을 할 때 사용되는 Symbol이다. 

Normal 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

ActiveX 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

 Wedge 

 StartAngle 

 EndAngle 

Bitmap 

화면에 배경그림을 삽입 할 때 사용 된다. 
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Normal 

Bitmap 

배경 그림은 다음과 같은 형태의 Graphic Format을 지원한다. 

 Bitmap (*.ico, *.bmp, *.dib) 

 PCX 

 TARGA 

 GIF 

 JPG 

 TIF 

배경그림은 자체 Editing Tool로도 편집이 가능하며 자세한 기능은 “Object편집”을 참조바

람. 

Layout 

Bitmap의 표시 위치를 지정한다. 

 Center – 중간에 위치 

 Left – 왼편에 위치 

 Right – 오른편에 위치 

 Stretch – 전체 크기로 확대 

 Size To Fit – 크기를 bitmap의 원래 크기에 맞게 자동 축소 

Layout이stretch 모드일 때에만 FlexHorizontal/FlexVertical이 동작된다. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

 TransparentColor 

Border 

화면에 보더를 그린다. 
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Normal 

Border Style  

 0 – Normal 

 1 – 3D 

 2 – Sunken(PenWidth값이 1이상일 경우 확인 가능) 

 3 - Raised(PenWidth값이 1이상일 경우 확인 가능) 

PenWidth 

Border의 선 굵기를 지정한다. 

Background Color가 보이지 않으며 선 굵기가0이 된 경우에는 해당 border가 

화면에서 보이지 않게 된다. 이 경우 Property창의 상단의 combobox에서 해당 

border를 선택할 수 있다. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

 HiliteColor 

 BorderStyle 

Button 

화면에 동작버튼을 그린다. 

동작버튼을 이용하여 화면간의 이동을 할 수 있으며 Script도 수행할 수 있다. 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Normal 

Alignment 

Bitmap  

Button에 이미지를 삽입하여 사용할 수 있다. 

사용방법은 Objects에Bitmap기능과 동일하게 사용할 수 있다. 
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ButtonShape 

Button의 모양을 선택한다. 

 Normal 

 Property Tab (InActive) 

 Property Tab (Active) 

Dynamic 

ButtonType 

Button이 눌러졌을 때의 동작을 지정한다. 

 OK – 현재 화면의 수정 데이터를 저장하고 닫는다 

 Cancel – 현재 화면의 수정 데이터를 저장하지 않은 채 닫는다 

 GotoView – 현재 화면을 닫고 새 화면으로 이동한다. 

 ShowView – 새 화면을 보여준다. 

 EventClick – EventClick에 지정된 script를 수행한다. 

 ShowModal – Modal 화면을 보여준다. 

 Record – 현재 화면의 수정 데이터를 저장한다. 

Modal 화면은 그 화면을 닫지 않고는 다른 화면으로 Focus를 넘길 수 없는 

화면을 말한다. 

GotoPath 

ButtonType이 GotoView, ShowView 혹은 ShowModal일 경우 새로 나타나는 화면을 지정

한다. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

 SpacerWidth 

 RunClick 
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Connector 

Object중 다음과 같은 작은 연결box가 나타나 있는 연결 가능한 개체들간의 연결선을 그

리는데 사용된다. 

Snap Point가 활성화 된 경우에만 connector를 사용할 수 있다. 

Normal 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Line 

화면에 텍스트를 그린다. 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Normal 

ArrowHead 

Border의 선의 속성을 지정한다. 

 0 - : ‘------‘로 지정 

 1 - : ‘-----’로 지정 

 2 - : ‘-----‘로 지정 

 3 - : ‘---’로 지정 
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ArrowHeadHeight 

PenStyle 

Line의 모양을 지정 한다. 

 0 – Solid 

 1 – Dash 

 2 – Dot 

 3 – Dash-Dot 

 4 – Dash-Dot-Dash 

PenWidth 

Line의 굵기를 설정한다.(PenStyle-Solid에 만 적용됨) 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

 SetEndPoints 

PolyLine 

왼쪽 마우스버튼을 누를 때 마다 line이 추가되며 오른쪽 마우스버튼을 누르면 추가가 끝

난다. 

Normal 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

 NumberOfPoints 

 SetPoint 
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 GetPointX 

 GetPointY 

Rectangle 

화면에 사각형을 그린다. 

Normal 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

ShadowStyle 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Text 

화면에 텍스트를 그린다. 

Text입력도중 다음 줄로 바꾸고자 할 때는 Ctrl 키를 누른 후Enter키를 친다. 

Normal 

Alignment 

입력한 Text를 정렬 할 때 사용한다. 

HatchStyle 

다음과 같은 모양의 Hatch선을 배경에다가 채운다. 

 0 – None 

 1 – Horizontal(---) 

 2 – Vertical(lll) 
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 3 – Diagonal(\\\) 

 4 – DiagRev(///) 

 5 – Cross(+++) 

 6 – DiagCross(xxx) 

ShadowStyle 

Text에 입체감을 주는데 사용된다. 

PenWidth 

Text Box의 선 굵기를 지정한다. 

Default 값은0으로 선이 보이지 않고 Text입력 값만 보인다. 

HiliteColor 

BorderStyle이 Sunken 또는 Raised 일 때 강조표현 색 

PenWidth가 1 이상일 경우 확인 가능 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

TextVar 

Dynamic 값의 지정이 가능한 텍스트를 그린다. 

Normal 

Format 

표시해야 할 값의 형식을 지정한다. 

형식은 C 언어의 printf형식중 [flags] [width] [.precision] 을 지정하면 된다. 

 Flag 

 Width – 표시해야 할 최소 자릿수를 지정 

 Precision 
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Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Window Control 

Window에서 제공되는 Control Symbol로 동적 Symbol보다 항상 위에 나타난다. 

Check 

화면에 체크버튼을 그린다. 

Normal 

Bitmap/BitmapOffState 

Image file로check의 상태를 표시할 때 지정한다. 

해당 bitmap은 반드시 가로,세로 크기가 동일한 정사각형이어야만 한다. 

OwnerDrawn 

지정된 bitmap을 사용할 지의 여부를 결정한다. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

 RunChange 

 IncrValue 
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ComboBox 

Normal 

ComboType 

 DropDown – Combo의 내용 중 하나를 선택한다. 

 DropList – Combo Item을 선택하거나 새로 입력한다. 

Height 

ComboBox의 높이는 사용되는 폰트의 크기로 고정되어 있으며 크기를 조정

하고 싶을 때에는 폰트를 먼저 바꾸어야 한다. 

ListItems 

Combobox에 표시해야 할 내용을 변경한다. 

NumDropped 

Combobox에 표시해야 할 내용의 개수를 지정한다. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

 AddString 

 DeleteString 

 ResetContent 

 RunChange 

 GetNumItems 

 TextValue 

 GetText 

 EditItem 

 AddItem 

 DeleteItem 

 Selection 
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EditBox 

한 줄의 내용을 입력할 때 사용 된다. 

EditBox의 높이는 사용되는 폰트의 크기로 고정되어 있으며 크기를 조정하고 

싶을 때에는 폰트를 먼저 바꾸어야 한다. 

Normal 

BorderDrawn 

테두리 선을 나타낼 지의 여부를 결정한다. 

UseColors 

지정된 색을 사용하여 표시할 지 여부를 지정한다. 

Dynamics 

CaseOrPassword 

Data의 표시형태를 지정한다. 

 None – Default 설정 값이다. 

 LowerCase – 입력 데이터를 소문자로 변환한다. 

 UpperCase – 입력 데이터를 대문자로 변환한다. 

Password – 입력 데이터를 보여주지 않는다. 

ReadOnly 

읽기 전용으로 사용할 지 결정한다. 

 0 – No : 읽기 전용으로 사용하고 입력은 할 수 없다. 

 1 – Yes : 내용을 입력 받을 수 있도록 설정 한다. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

 GetWindowText 

 SetWindowText 
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ListBox 

Normal 

HorizontalScroll 

List Box에Scroll를 사용을 지정한다. 

 0 – No :  Scroll를 사용 안 함. 

 1 – Yes : Scroll를 사용함. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

 AddString 

 DeleteString 

 ResetContent 

 GetNumItems 

 GetText 

 GetCurSel 

 SetCurSel 

MultiEditBox 

EditBox와는 달리 여러 줄의 내용을 입력할 때 사용된다. 

Normal 

HorizontalScroll 

가로축의 Scroll 사용을 결정 한다. 

 0 – None : Default 설정 값 

 1 – Always : 항상 Scroll를 사용함 

 2 – Automatic : 입력 값에 의해서 자동으로 Scroll를 생성함. 

VerticalScroll 

세로축의 Scroll 사용을 결정한다. 
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 0 – None : Default 설정 값 

 1 – Always : 항상 Scroll를 사용함 

 2 – Automatic : 입력 값에 의해서 자동으로 Scroll를 생성함. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

 GetLineCount 

 GetLineOfText 

 SelectedText 

Radio 

화면에 Radio버튼을 그린다. 

Normal 

ListItems  

Radio 버튼의 입력 List를 만들 때 사용된다. 

2 Items : 2개의 Radio 입력 버튼을 사용한다. 

설정 값에서 추가하면 여러 개의 Radio 입력 List를 만들 수 있다. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Slider 

화면에 Slider를 그린다. 
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Normal 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Spinner 

화면에 Spinner를 그린다. 

Normal 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Component 

ActiveX module이며 Property창에 ActiveX속성 창이 추가되어 나타난다. 
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QCTrend 

화면에 실시간 Trend 창을 그린다. 

Normal 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Event 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

ActiveX 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 

Method 

기본적인 설정 값은 Objects의 설정 값과 동일 하다. 
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5. Catalog 작성 

열기 

Menu  View  Catalog로 파일을 열수 있다. 

 

그림 5-1 Catalog 

Catalog 열기 

Drag & Drop으로 선택된 항목을 catalog에 추가할 수 있다.  오른쪽 마우스를 눌러 메뉴항목에서 

복사를 선택한 후 작업 창에 붙여넣기를 하는 방법도 동일하다. 
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File로 열기하기 

Default로 제공된 Catalog외에 다른 파일을 추가하여 사용할 수 있다. 

Catalog File은 *.dct이다. 

 

그림 5-2 File 열기 
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6. Script 작성 

Script 

Script는 모든 object에 지정할 수 있다. 

Script편집 창과 View창은 아래의 단축icon을 누르면 각각 나타난다. 

System 함수 

Global 함수 

 PulseOn 

 PulseOff 

 Shutdown 

 ChekPassword 

Application 함수 

 Start 

 End 

 TimerMonth 

 TimerDay 

 TimerHour 

 TimerMinute 

 TimerSecond 

 TimerLoop 

Keyboard 함수 

키보드의 단축키에 스크립트 명령어를 지정 할 수 있다. 

Sub KeyboardFuncs_F10(bAlt,BCtrl,BShift) 
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GlobalFuncs.FullScreen True  

End Sub 

사용자 Routine 

Global 함수 

Global 함수는 모든 View에서 사용할 수 있는 routine을 정의한다. 정의 된 함수는 project 

folder의declare.bas의 이름으로 저장된다. 

이 함수는 Call명령으로 반복하여 사용 가능하다. 

Local 함수 

Variables 

전역변수 

DataBase program에서 작성된 tag들은 모든 view에서 사용할 수 있는 전역변수이다. 
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지역변수 

편집 창 사용 

 

그림 6-1 편집창 

VB Script 편집창 

편집 창에서 마침표(.) 에 해당되는 키를 누르면 사용 가능한 모든 개체가 표시된다. 
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Run Debugging 

Breakpoint 

Debugging 

Breakpoint가 설정된 View를 열었을 때 동작 컴퓨터에 Microsoft Development 

Environment 6.0가 설치된 경우 다음과 같은 dialog box가 나타난다. 

 

 

그림 6-2 Debugging 

Debugging  

두개의 dialog box에 차례대로 Yes -> No를 입력하면 해당 script code를debugging할 수 

있다. 

자주 쓰이는 단축키는 다음과 같다. 

 F5 -> Continue 

 F10 -> Trace Over 

 F11 -> Trace Into 
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기본적인 VBScript 

색깔지정 

기본색상 

Constant Value Description 

VbBlack &h00 Black 

VbRed &hFF Red 

VbGreen &hFF00 Green 

VbYellow &hFFFF Yellow 

VbBlue &hFF0000 Blue 

VbMagenta &hFF00FF Magenta 

VbCyan &hFFFF00 Cyan 

VbWhite &hFFFFFF White 

응용색상 

RGB 색코드 색 

RGB 0.0.0 검정 

RGB 255.255.255 흰색 

RGB 128.128.128 어두운 회색 

RGB 192.192.192 밝은 회색 

RGB 128.0.0 어두운 회색 
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RGB 255.0.0 빨간색 

RGB 128.128.0 어두운 노란색 

RGB 255.255.0 노란색 

RGB 0.128.0 어두운 녹색 

RGB 0.255.0 녹색 

RGB 0.128.128 어두운 청녹색 

RGB 0.255.255 청녹색 

RGB 0.0.128 어두운 파란색 

RGB 0.0.255 파란색 

RGB 128.0.128 어두운 자홍색 

RGB 255.0.255 자홍색 

RGB 128.255.128 밝은 녹색 

RGB 128.255.255 밝은 청녹색 

RGB 255.255.128 밝은 노란색 

RGB 128.128.255 밝은 파란색 

RGB 255.128.128 밝은 빨간색 

 

기타 색은 PhotoShop의 색 사용하는 방법과 동일하다. 

MsgBox 

Description 

Displays a message in a dialog box, waits for the user to click a 

button, and returns a value indicating which button the user clicked. 
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Syntax 

MsgBox(prompt[, buttons][, title][, helpfile, context]) 

Remarks 

The following example uses the MsgBox function to display a 

message box and return a value describing which button was 
clicked: 

Dim MyVar 

MyVar = MsgBox (“Hello World!”, 65, “MsgBox 

Example”) ‘ MyVar contains either 1 or 2,   

응용예제 

3가지이상의 상태표시 

사각형을 그리고 EventPumpData에 다음과 같이 추가한다. 

Sub Text1_EventPumpData() 

Dim This : Set This = Text1 

If M0101FAULT=True Then 

If THis.BackColor <> vbYellow Then 

This.BackColor=vbYellow 

End If 

Else If M0101RUN=True Then 

If THis.BackColor <> vbRed Then 

This.BackColor=vbRed 

End If 

Else If M0101STOPPED=True Then 

If THis.BackColor <> vbGreen Then 

This.BackColor=vbGreen 

End If 

Else If THis.BackColor <> vbWhite Then 

This.BackColor=vbWhite 

End If 

End If 

End Sub  
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일정시간이 흐른 지 확인 

Global에 다음의 변수를 정의한다. 

’(GlobalDeclarations) 

Dim lastTime 

‘--------------------------------------------- 

‘End of (GlobalDeclarations) 

Bitmap을 그리고 EventInitialize를 다음과 같이 입력한다. 

Sub Bitmap1_EventInitialize() 

Dim This : Set This = Bitmap1 

lastTime = now 

End Sub  

 

EventPumpData에 다음과 같은 Routine을 추가한다. 

Sub Bitmap1_EventPumpData() 

Dim This : Set This = Bitmap1 

Dim currTime 

currTime = Now 

If (DateDiff (“s”, lastTime, currTime) < 3) Then 

Exit Sub 

End If 

lastTime = currTime 

If (This.Bitmap = “on.bmp”) Then  

This.Bitmap = “off.bmp” 

Else 

This.Bitmap = “on.bmp” 

End If 

End Sub  

초기화면 표시 후 다른 화면으로 자동 이동 

View의EventInitialize에 다음과 같은 Routine을 추가한다. 
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Sub TheView_EventInitialize() 

Dim This : Set This = TheView 

‘ 1초동안 sleep한다 

TheView.GUISleep(1000)  

TheView.ShowView “overview.dvw”, 0, 0 

End Sub  

Mouse 오른쪽 Button Click때 화면 이동 

View의EventInitialize에 다음과 같은 Routine을 추가한다. 

Sub Text1_EventMouseDown(Button, Shift, X, Y) 

Dim This : Set This = Text1 

If (button = 2) Then 

TheView.ShowModal “dlgbox.dvw”, 0, 0 

End If 

End Sub 

다른 View를 제어하기 

View#1의EventInitialize에 다음과 같은 Routine을 추가한다. 

Sub TheView_EventInitialize() 

Dim This : Set This = TheView 

TheView.ShowView “Child.dvw”, 0, 0 

End Sub  

View#1에button을 추가하고 다음과 같은 Routine을 추가한다. 

Sub Button1_EventClick() 

Dim This : Set This = Button1 

Dim otherForm 

Set otherForm = TheView.FormFind(“CHILD”) 

If (IsObject(otherForm)) Then 

otherForm.Text1.Text = EditBox1.Text 

End If 

End Sub  

View#2를 생성하고 (FormCode)에 CHILD라고 설정한다. 

View#2에Text Object를 생성하고 Text1이라고 (ObjectCode)설정한다. 
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View에 ODBC Field를binding하기 

View에RDC ActiveX를 삽입하고 다음과 같이 설정한다. 

 DataSourceName -> PanelData 

 SQL -> SELECT * FROM dbpanel 

View에Masked Edit ActiveX를 삽입하고 (ObjectCode)에 다음과 같이 설정한다. 

 Pnumber 

 PLocation 

View의Initialize에 다음과 같이 설정한다. 

Sub TheView_EventInitialize() 

Dim This : Set This = TheView 

Dim theSQL 

‘Binding data fields 

This.BindDefaultProperty  PNumber ,  “Text”,”PNumber”,   PanelData 

This.BindDefaultProperty   PLocation,  “Text”,”PLocation”,  PanelData 

This.BindDefaultProperty  PYear,        “Text”,”PYear”,        PanelData 

OnPanelChanged 

End Sub  

View의Declaration에 다음의 함수를 만든다. 

‘ Declarations Local to “TheView” 

Sub OnPanelChanged() 

Dim StrSQL 

Dim theSet 

If (CPId.Value < 0) Then 

Exit Sub 

End If 

theSQL = “SELECT * FROM [DbPannel] WHERE ID =” & CPId.Value 

PanelData.SQL = theSQL 

PanelData.Refresh 

End Sub 

‘ End of Declarations Local to “TheView” 

View의EventDSC에 다음의 함수를 만든다. 

Sub TheView_EventDSC(objDSCData) 

Dim This : Set This = TheView 

If (objDSCData.strObjCode=”PanelData” And objDSCData.nDSCReason=dscMove And obj

DSCData.nDSCState=dscDidEvent) Then 

OnPanelChanged 

End If 
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End Sub  

역률 계산 

AI007의Tag에서 값을 받아 계산후 1_PF_HV3로 역률 값을 돌려 준다. 

Sub AI007_NEWData(RValue) 

Dim rPfValue 

‘ rValue 0-100 % 

If (rValue < 50) Then 

rValue = - rValue – 50 

Else 

rValue= 150 - rValue 

End If 

1_PF_HV3 = rValue 

End Sub  

주기적으로 함수 수행하기 

Sub Application_TimeerHour(nHour) 

GlobalFuncs.PulseOn MX3000.Name, 2000  

End Sub  

Keyboard에 의한 FullScreen 제어 

F10키로 전체화면 보기. 

Sub KeyboardFuncs_F10(bAlt,BCtrl,BShift) 

GlobalFuncs.FullScreen True  

End Sub  

공통의 Dialog창 띄우기 

Popup 창을 작성한다. (Pulse.dwg) 
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그림 6-3 공통 Dialog 창 

변수를 전달할 수 있는 Global Tag를 만든다. 

String1, String2, String3, String4, String5 

변수전달을 처리하는 Global함수를 만든다. 

Popup 창을 띄우기 전에 Tag를 전달하는 함수 

Sub ShowPulseDialog(Parent, Name, Comment, Status, OnCmd, OffCmd) 

 ‘ glogal tag를 이용하여 Tag전달 

String1 = Name 

String2 = Comment 

String3 = Status 

String4 = OnCmd 

String5 = OffCmd 

‘ Popup 창을 띠움 

TheView.ShowModal “Pulse.dvw”, -1, -1 

End Sub 

창을 띄우는 개체에 ClickEvent를 만든다. 

ShowPulseDialog This, “GCP ACB”, “GCP ACB CONTROL”, “IX061

1”, “QX0714”, “QX0715” 

Popup창에서 사용되는 변수의 초기화 함수를 EventInitialize에 만든다. 
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Sub OffCommand_EventInitialize() 

Dim This : Set This = OffCommand 

This.SetValueEq 12, String5.Value 

This.SetValueSet 12, String5.Value 

End Sub  

Sub OnCommand_EventInitialize() 

Dim This : Set This = OnCommand 

This.SetValueEq 12, String4.Value 

This.SetValueSet 12, String4.Value 

End Sub  

미리보기 버튼 

Draw작업 화면에서 버튼을 만든다. 

버튼의 클릭 이벤트에 다음의 코드를 삽입한다. 

Sub btnPreView_EventClick() 

Dim This : Set This = btnPreView 

  TheView.HardCopy True 

End Sub 

인쇄 버튼 

Draw작업 화면에서 버튼을 만든다. 

버튼의 클릭 이벤트에 다음의 코드를 삽입한다. 

Sub btnPrint_EventClick() 

Dim This : Set This = btnPrint 

 TheView.HardCopy False 

End Sub 
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